Help Centre

   
 
 

Upgrading to Attaché 19.2

This topics describes how to upgrade to Attaché 19.2, including upgrading Attaché Database Server, the Attaché application and workstations. If you are unsure about the upgrading procedure or need assistance to upgrade, talk to your Attaché consultant before you begin.

Important note: You can upgrade to Attaché 19 only from Attaché BI version 3.5 (November 2016) or later. If you are using an earlier version, talk to your Attaché consultant. Upgrading from these earlier versions requires a data migration which must be carried out by a certified Attaché installer.

Before you begin

Prior to upgrading, ensure your system:

 Click here to expand...
  • Attaché 18 or later, including Attaché 19.2, requires Microsoft .NET Framework version 4.5.2. (Previously.NET 4.5.1 was required.) .NET Framework 4.5.2 has been packaged with the InstallShield wizard. When installing Attaché 19.2 you will be prompted to install .NET 4.5.2, if it is not already installed. 
  • Before Attaché 19.2 can be installed on Windows Server 2008R2 or Windows 7, you need to install a Microsoft update. See Update for Windows 7 (KB2533623) or Update for Windows Server 2008 R2 x64 Edition (KB2533623). (Note that we do not recommend installing the server components on Windows 7.)
  • Attaché 19.2 cannot run on Windows 2008, 2008SP1 or 2008SP2 (or any earlier operating systems).


Before you begin the upgrade process: 

  • Read the Attaché 19.2 Release Notes
  • Check the Attaché Members website for any known issues with this release and read any additional notes on the download page 
  • Post any outstanding transactions to the general ledger.
  • Take a backup of your Attaché data
  • Exit Attaché and ensure that no one else is using it 
  • Temporarily disable any antivirus software to ensure it doesn't interfere during the upgrad

Downloading files

Talk to you Attaché consultant or visit the Attaché Members website to download the latest software files including Attaché Database Server file (32-bit or 64-bit), Attaché application and any related Attaché products that you use, such as Attaché Asset Management.

Upgrading Attaché Database Server 

You must upgrade Attaché Database Server before you upgrade the Attaché desktop application. 

To upgrade Attaché Database Server:

  1. Ensure all users are logged out of Attaché. 
  2. Stop all four Attaché services through the services console (services.msc).
  3. Disable any antivirus software.
  4. In the saved files directory, right click the attache-database-server-32- (or 64-) bit-installer-19.x.x.exe file and select Run as administrator.
  5. When asked Do you want to run this file? choose Run.
    This launches the InstallShield Wizard.
  6. Click Next to start the installation.
  7. When the installation is complete, choose Finish to close the InstallShield Wizard.

Upgrading the Attaché desktop application

To upgrade the Attaché application:

  1. In the saved files directory, right click the attache-application-installer-19.x.x.exe file and select Run as administrator. 
  2. When asked Do you want to run this file? choose Run.
    This launches the InstallShield Wizard.
  3. Click Next and then click Install to start the installation.
  4. When the installation is complete, choose Finish to close the InstallShield Wizard.

Updating antivirus exceptions

Update your antivirus software exclusions, if applicable (see Antivirus exclusions list).

Checking your installation

Check the application:

  1. Log in to Attaché and choose Help | About Attaché.
  2. Check that the Release number is Attaché 19.2.x.  

Check company-organisation connections: 

  • From the main menu on the Attaché desktop, choose Online Services | Cloud Connector. Click View all company connections and ensure your connections are listed. 

If either of the above checks fail, contact your Attaché consultant for assistance. 

Upgrading Attaché workstation

When you run Attaché at each workstation for the first time after upgrading, you may be prompted to install a new version of Attaché workstation. If an upgrade is required, the message Install the Attaché Workstation components now? is displayed.

To upgrade an Attaché workstation:

  1. At the workstation, right-click the Attaché application desktop shortcut and select Run as administrator

    If a workstation upgrade is required, the message Install the Attaché Workstation components now? is displayed.

  2. Click Yes to open the InstallShield Wizard.
  3. Click Next on the Welcome page to proceed.
    Before upgrading the workstation, the software checks if the Microsoft .NET 4.5 Framework is installed. If not, you will be prompted to install it. You may then be prompted to restart your computer. If so, after the restart, start Attaché again to relaunch the workstation upgrade.
  4. Follow the onscreen instructions.
  5. When finished, the Wizard Complete page is displayed.
  6. Click Finish to close the installation wizard. 
  7. If prompted to restart your computer, do so. After restarting you can then run Attaché as usual. If not prompted to restart your computer, Attaché will start immediately after you close the installation wizard.

Note: Additional antivirus exceptions For each workstation, you may need to update your antivirus exceptions (see Antivirus exclusions list). 

Upgrading related Attaché products

After upgrading Attaché, you should check for upgrades to your other Attaché products including Attaché Server ODBC, Attaché ClearView, Attaché Asset Management (formerly Attaché Fixed Assets) and AlexConnect. See Current Attaché releases (compatibility list)


REF 240220  192

Applicable versions

  • Attaché 19 suite

See also Current Attaché releases

Upgrade related products

You should check for upgrades for your other Attaché products, especially if you have not upgraded for some time. See Current Attaché releases